re = /<(span).*?class="\s*(?:.*\s)?wpcf7[^\>]*>(.*)<\/\1>/i
str = '<span class="wpcf7-form-control wpcf7-acceptance">
<span class="wpcf7-list-item">
<input type="checkbox" name="our-policy" value="1" aria-invalid="false" class="form-check-input" id="our-policy">
</span>
</span>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end