use strict;
my $str = '<span class="wpcf7-form-control wpcf7-acceptance">
<span class="wpcf7-list-item">
<input type="checkbox" name="our-policy" value="1" aria-invalid="false" class="form-check-input" id="our-policy">
</span>
</span>';
my $regex = qr/<(span).*?class="\s*(?:.*\s)?wpcf7[^\>]*>(.*)<\/\1>/isp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}