# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@aaa\|sss/55/gm;t' <<< "Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5"