#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)@aaa\|sss"
Local $sString = "Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5"
Local $sSubst = "55"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)