const regex = /@aaa\|sss/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('@aaa\\|sss', 'gm')
const str = `Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5`;
const subst = `55`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);