use strict;
my $str = 'Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5';
my $regex = qr/@aaa\|sss/mp;
my $subst = '55';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";