package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)@aaa\|sss`)
var str = `Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5`
var substitution = "55"
fmt.Println(re.ReplaceAllString(str, substitution))
}