// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)@aaa\|sss").unwrap();
let string = "Word1 Word2 @aaa|sss Word3 Word4 @aaa|sss Word5";
let substitution = "55";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}