using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".";
string input = @"paul@taming.tech
paul@osh.co.za
test-email@domain
New_email@domain.verylongtld
first.last@bananarama.ac.za
this is not real @ fake domain name
a@a.co
hello@testingname.okinawa
hello@testingname.jpn.com
hello@testingname.nom.es
hello@testingname.security";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}