import Foundation
let pattern = #"."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
paul@taming.tech
paul@osh.co.za
test-email@domain
New_email@domain.verylongtld
first.last@bananarama.ac.za
this is not real @ fake domain name
a@a.co
hello@testingname.okinawa
hello@testingname.jpn.com
hello@testingname.nom.es
hello@testingname.security
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)