// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).").unwrap();
let string = "paul@taming.tech
paul@osh.co.za
test-email@domain
New_email@domain.verylongtld
first.last@bananarama.ac.za
this is not real @ fake domain name
a@a.co
hello@testingname.okinawa
hello@testingname.jpn.com
hello@testingname.nom.es
hello@testingname.security";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}