package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).`)
var str = `paul@taming.tech
paul@osh.co.za
test-email@domain
New_email@domain.verylongtld
first.last@bananarama.ac.za
this is not real @ fake domain name
a@a.co
hello@testingname.okinawa
hello@testingname.jpn.com
hello@testingname.nom.es
hello@testingname.security`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}