$re = '/./m';
$str = 'paul@taming.tech
paul@osh.co.za
test-email@domain
New_email@domain.verylongtld
first.last@bananarama.ac.za
this is not real @ fake domain name
a@a.co
hello@testingname.okinawa
hello@testingname.jpn.com
hello@testingname.nom.es
hello@testingname.security';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);