import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".";
final String string = "paul@taming.tech\n"
+ "paul@osh.co.za\n"
+ "test-email@domain\n"
+ "New_email@domain.verylongtld\n"
+ "first.last@bananarama.ac.za\n"
+ "this is not real @ fake domain name\n"
+ "a@a.co\n"
+ "hello@testingname.okinawa\n"
+ "hello@testingname.jpn.com\n"
+ "hello@testingname.nom.es\n"
+ "hello@testingname.security";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}