#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""private_key": "\K[^\"]*"
Local $sString = "{" & @CRLF & _
" "project_id": "my-project-id"," & @CRLF & _
" "private_key_id": "pr1v@t3K3y"," & @CRLF & _
" "private_key": "-----BEGIN PRIVATE KEY-----\nMyKey\n-----END PRIVATE KEY-----\n"," & @CRLF & _
" "client_id": "1832734277128"," & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")