const regex = /"private_key": "\K[^\"]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"private_key": "\\K[^\\"]*', 'g')
const str = `{
"project_id": "my-project-id",
"private_key_id": "pr1v@t3K3y",
"private_key": "-----BEGIN PRIVATE KEY-----\\nMyKey\\n-----END PRIVATE KEY-----\\n",
"client_id": "1832734277128",
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}