import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"private_key\": \"\\K[^\\\"]*";
final String string = "{\n"
+ " \"project_id\": \"my-project-id\",\n"
+ " \"private_key_id\": \"pr1v@t3K3y\",\n"
+ " \"private_key\": \"-----BEGIN PRIVATE KEY-----\\nMyKey\\n-----END PRIVATE KEY-----\\n\",\n"
+ " \"client_id\": \"1832734277128\",\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}