$re = '/"private_key": "\K[^\"]*/';
$str = '{
"project_id": "my-project-id",
"private_key_id": "pr1v@t3K3y",
"private_key": "-----BEGIN PRIVATE KEY-----\\nMyKey\\n-----END PRIVATE KEY-----\\n",
"client_id": "1832734277128",
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);