import Foundation
let pattern = #""private_key": "\K[^\"]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"project_id": "my-project-id",
"private_key_id": "pr1v@t3K3y",
"private_key": "-----BEGIN PRIVATE KEY-----\nMyKey\n-----END PRIVATE KEY-----\n",
"client_id": "1832734277128",
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)