using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""private_key"": ""\K[^\""]*";
string input = @"{
""project_id"": ""my-project-id"",
""private_key_id"": ""pr1v@t3K3y"",
""private_key"": ""-----BEGIN PRIVATE KEY-----\nMyKey\n-----END PRIVATE KEY-----\n"",
""client_id"": ""1832734277128"",
}
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}