# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\\\\/:*?\x22<>|]//gmi;t' <<< "\Te\st/
Tes*t1
\"Test*2
Te<st:3
Te>st?4
Te\"st>5"