using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"{IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}";
string input = @"// Does NOT Work with html tags//
{IF:(!isset($_SESSION['loggedin']))}
<div>
<p>This code no longer works</p>
<p>Remove this div and everything will work.</p>
</div>
{ELSE}
Bleh
{ENDIF}
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}