package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i){IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}`)
var str = `// Does NOT Work with html tags//
{IF:(!isset($_SESSION['loggedin']))}
<div>
<p>This code no longer works</p>
<p>Remove this div and everything will work.</p>
</div>
{ELSE}
Bleh
{ENDIF}
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}