re = /{IF:(.*?)}[\s]*?(.*?)[\s]*?{ELSE}[\s]*?(.*?)[\s]*?{ENDIF}/i
str = '// Does NOT Work with html tags//
{IF:(!isset($_SESSION[\'loggedin\']))}
<div>
<p>This code no longer works</p>
<p>Remove this div and everything will work.</p>
</div>
{ELSE}
Bleh
{ENDIF}
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end