using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hspace=""10"">(.+)<";
string input = @"<div class=""qselections"">
<img src=""/images/tickbox.gif"" alt="" hspace=""10"">doing
<img src=""///images/tickedbox.gif"" alt="" hspace=""10"">be
<img src=""//images/tickbox.gif"" alt="" hspace=""10"">been
<img src=""//images/tickbox.gif"" alt="" hspace=""10"">by<br>
<img src=""//images/tickbox.gif"" alt="" hspace=""10"">out<br>
<img src=""//images/tickedbox.gif"" alt="" hspace=""10"">over<br>
</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}