import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "hspace=\"10\">(.+)<";
final String string = "<div class=\"qselections\">\n"
+ "<img src=\"/images/tickbox.gif\" alt=\"\" hspace=\"10\">doing\n"
+ "<img src=\"///images/tickedbox.gif\" alt=\"\" hspace=\"10\">be\n"
+ "<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">been\n"
+ "<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">by<br>\n"
+ "<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">out<br>\n"
+ "<img src=\"//images/tickedbox.gif\" alt=\"\" hspace=\"10\">over<br>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}