import Foundation
let pattern = #"hspace="10">(.+)<"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="qselections">
<img src="/images/tickbox.gif" alt="" hspace="10">doing
<img src="///images/tickedbox.gif" alt="" hspace="10">be
<img src="//images/tickbox.gif" alt="" hspace="10">been
<img src="//images/tickbox.gif" alt="" hspace="10">by<br>
<img src="//images/tickbox.gif" alt="" hspace="10">out<br>
<img src="//images/tickedbox.gif" alt="" hspace="10">over<br>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)