package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)hspace="10">(.+)<`)
var str = `<div class="qselections">
<img src="/images/tickbox.gif" alt="" hspace="10">doing
<img src="///images/tickedbox.gif" alt="" hspace="10">be
<img src="//images/tickbox.gif" alt="" hspace="10">been
<img src="//images/tickbox.gif" alt="" hspace="10">by<br>
<img src="//images/tickbox.gif" alt="" hspace="10">out<br>
<img src="//images/tickedbox.gif" alt="" hspace="10">over<br>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}