// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)hspace="10">(.+)<"#).unwrap();
let string = "<div class=\"qselections\">
<img src=\"/images/tickbox.gif\" alt=\"\" hspace=\"10\">doing
<img src=\"///images/tickedbox.gif\" alt=\"\" hspace=\"10\">be
<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">been
<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">by<br>
<img src=\"//images/tickbox.gif\" alt=\"\" hspace=\"10\">out<br>
<img src=\"//images/tickedbox.gif\" alt=\"\" hspace=\"10\">over<br>
</div>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}