using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\w+['’])?\w+(?:-(?:\w+['’])?\w+)+|\w+['’]\w+";
string input = @"O'Hara-O’Mara
O'Hara
O’Mara
Kara
1234
abc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}