import re
regex = re.compile(r"(?:\w+['’])?\w+(?:-(?:\w+['’])?\w+)+|\w+['’]\w+", flags=re.MULTILINE)
test_str = ("O'Hara-O’Mara\n"
"O'Hara\n"
"O’Mara\n"
"Kara\n\n"
"1234\n"
"abc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")