re = /(?:\w+['’])?\w+(?:-(?:\w+['’])?\w+)+|\w+['’]\w+/m
str = 'O\'Hara-O’Mara
O\'Hara
O’Mara
Kara
1234
abc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end