$re = '/(?:\w+[\'’])?\w+(?:-(?:\w+[\'’])?\w+)+|\w+[\'’]\w+/m';
$str = 'O\'Hara-O’Mara
O\'Hara
O’Mara
Kara
1234
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);