using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+)\bby\b(.+)$";
string substitution = @"$1: $2";
string input = @"Death by Blackhole by Tyson";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}