package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(.+)\bby\b(.+)$`)
var str = `Death by Blackhole by Tyson`
var substitution = "$1: $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}