import re
regex = re.compile(r"^(.+)\bby\b(.+)$")
test_str = "Death by Blackhole by Tyson"
subst = "$1: $2"
result = regex.sub(subst, test_str)
if result:
print(result)