#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-zA-Z]+?)([-\s'][a-zA-Z]+)*?$"
Local $sString = "" & @CRLF & _
"#should only start with alphabets" & @CRLF & _
"John" & @CRLF & _
"1John" & @CRLF & _
"-John" & @CRLF & _
" John" & @CRLF & _
"\John" & @CRLF & _
"#Can contain spaces,- and ' but should not repeat consecutively, also there should be alphabets before and after allowed special chars" & @CRLF & _
"John Doe" & @CRLF & _
"John-Doe" & @CRLF & _
"John's Doe" & @CRLF & _
"John--Doe" & @CRLF & _
"John Doe" & @CRLF & _
"John' s" & @CRLF & _
"John-Doe-" & @CRLF & _
"" & @CRLF & _
"#Other special chars not allowed" & @CRLF & _
"John#Doe" & @CRLF & _
"J0hn" & @CRLF & _
"JON3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")