re = /^([a-zA-Z]+?)([-\s'][a-zA-Z]+)*?$/m
str = '
#should only start with alphabets
John
1John
-John
John
\\John
#Can contain spaces,- and \' but should not repeat consecutively, also there should be alphabets before and after allowed special chars
John Doe
John-Doe
John\'s Doe
John--Doe
John Doe
John\' s
John-Doe-
#Other special chars not allowed
John#Doe
J0hn
JON3
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end