using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z]+?)([-\s'][a-zA-Z]+)*?$";
string input = @"
#should only start with alphabets
John
1John
-John
John
\John
#Can contain spaces,- and ' but should not repeat consecutively, also there should be alphabets before and after allowed special chars
John Doe
John-Doe
John's Doe
John--Doe
John Doe
John' s
John-Doe-
#Other special chars not allowed
John#Doe
J0hn
JON3
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}