const regex = /^([a-zA-Z]+?)([-\s'][a-zA-Z]+)*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]+?)([-\\s\'][a-zA-Z]+)*?$', 'gm')
const str = `
#should only start with alphabets
John
1John
-John
John
\\John
#Can contain spaces,- and ' but should not repeat consecutively, also there should be alphabets before and after allowed special chars
John Doe
John-Doe
John's Doe
John--Doe
John Doe
John' s
John-Doe-
#Other special chars not allowed
John#Doe
J0hn
JON3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}