# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([a-zA-Z]+?)([-\s'][a-zA-Z]+)*?$"
test_str = ("\n"
"#should only start with alphabets\n"
"John\n"
"1John\n"
"-John\n"
" John\n"
"\\John\n"
"#Can contain spaces,- and ' but should not repeat consecutively, also there should be alphabets before and after allowed special chars\n"
"John Doe\n"
"John-Doe\n"
"John's Doe\n"
"John--Doe\n"
"John Doe\n"
"John' s\n"
"John-Doe-\n\n"
"#Other special chars not allowed\n"
"John#Doe\n"
"J0hn\n"
"JON3\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.