import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]+?)([-\\s'][a-zA-Z]+)*?$";
final String string = "\n"
+ "#should only start with alphabets\n"
+ "John\n"
+ "1John\n"
+ "-John\n"
+ " John\n"
+ "\\John\n"
+ "#Can contain spaces,- and ' but should not repeat consecutively, also there should be alphabets before and after allowed special chars\n"
+ "John Doe\n"
+ "John-Doe\n"
+ "John's Doe\n"
+ "John--Doe\n"
+ "John Doe\n"
+ "John' s\n"
+ "John-Doe-\n\n"
+ "#Other special chars not allowed\n"
+ "John#Doe\n"
+ "J0hn\n"
+ "JON3\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}