# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+\.\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\d{3})+(?!\.|\d))/,/gm;t' <<< "123456789123456789123456789
123456789
1234567
123456781234567812345678.111111111111111
34.345"