import re
regex = re.compile(r"\d+\.\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\d{3})+(?!\.|\d))", flags=re.MULTILINE)
test_str = ("123456789123456789123456789\n"
"123456789\n"
"1234567\n"
"123456781234567812345678.111111111111111\n"
"34.345")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)