$re = '/\d+\.\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\d{3})+(?!\.|\d))/m';
$str = '123456789123456789123456789
123456789
1234567
123456781234567812345678.111111111111111
34.345';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;