const regex = /\d+\.\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\d{3})+(?!\.|\d))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\.\\d*(*SKIP)(*FAIL)|(?!^)(?=(?:\\d{3})+(?!\\.|\\d))', 'gm')
const str = `123456789123456789123456789
123456789
1234567
123456781234567812345678.111111111111111
34.345`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);