#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/yandex\.ru\/\w+\/\w+\/\w+\/(\w+)$"
Local $sString = "https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu" & @CRLF & _
"https://yandex.ru/bbbb/kkkk/TARGET/mmmm" & @CRLF & _
"https://yandex.ru/ccccc/eeee/TARGET/nnnnnn"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")