re = /^https:\/\/yandex\.ru\/\w+\/\w+\/\w+\/(\w+)$/m
str = 'https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu
https://yandex.ru/bbbb/kkkk/TARGET/mmmm
https://yandex.ru/ccccc/eeee/TARGET/nnnnnn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end