using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/yandex\.ru\/\w+\/\w+\/\w+\/(\w+)$";
string input = @"https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu
https://yandex.ru/bbbb/kkkk/TARGET/mmmm
https://yandex.ru/ccccc/eeee/TARGET/nnnnnn";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}