$re = '/^https:\/\/yandex\.ru\/\w+\/\w+\/\w+\/(\w+)$/m';
$str = 'https://yandex.ru/aaaaa/ggg/TARGET/uuuuuu
https://yandex.ru/bbbb/kkkk/TARGET/mmmm
https://yandex.ru/ccccc/eeee/TARGET/nnnnnn';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);